Topic Messages  
HomeHome HelpHelp Sign upSign up Log inLog in

Zetorworld forum
Tractor forum
Alternator charge light not working?

Moderators: Renze, TomZ

The Web Zetorworld.com only
Zetormad


Posts: 33



Alternator charge light not working?  
  Started at Thu Jan 17 21:11:39 2008
deviousThe Red Ignition light is not working but tractor seems to be charging OK ?Is there a bulb that might need changing or a wire that may have come undone ? 5911

 
  ProfileProfile Send MessageSend Message  


Saskatchewan


Posts: 4
Gender:


Re: Alternator charge light not working?  
  Reply #1 Posted at Thu Jan 17 22:14:16 2008
How do you know it is working? Voltage or amp check on the line?

The reason I ask is that my charge light stays on after startup at low RPM's - then after a few minutes and RPM>800 it flickers and goes out.


1995 4340
 
  ProfileProfile Send MessageSend Message  


juney68


Posts: 36



Re: Alternator charge light not working?  
  Reply #2 Posted at Tue Jan 22 22:42:16 2008
I had the same problem on my 7745 and it was just the wire had fallen off at the light socket. Could also be the bulb. juney

 
  ProfileProfile Send MessageSend Message  


billmcneil


Posts: 7

Re: Alternator charge light not working?  
  Reply #3 Posted at Sun Sep 7 03:00:55 2008
Hi in my operators manual it says that the if the bulb is burned out the alternator will not charge that it is wired in a series and if it burns out it quits charging, says the light should come on with the key on and go off when the tractor starts

 
  ProfileProfile Send MessageSend Message  


Member List Member List
Who's online: 29 guests


This forums webmaster: webmaster(at)zetorworld.com